hauptseite

10. November 2006

Ubuntu Edgy: Webcams mit pwc Treiber produzieren graues Bild. Ein Workaround.

Kategorie: — Suzan @ 20:39 Uhr

Edgy-Nutzer einer Webcam mit pwc-Treiber werden es schon gemerkt haben; obwohl die Cam unter Dapper out-of-the-box funktioniert hat produziert sie unter Edgy nur noch ein graues Bild.
Das ist ärgerlich, der Grund ist in diesem Bugreport zu finden. Wegen Lizenzschwierigkeiten ist der pwc-Treiber wohl in einer verstümmelten Version in den 2.6.17er Edgy-Kernel gekommen. ;-(
Anscheinend ist das im Kernel 2.6.18 wieder behoben, aber das nutzt Edgy-Nutzer nichts, die nicht gleich einen Kernel selber kompilieren wollen.

Zum Glück gibt es eine Möglichkeit den pwc-Treiber per Hand zu installieren.

Infos zum pwc-Treiber pwc-10.0.12-rc1 hier, hier der Direktlink zum Download.

Das File pwc-10.0.12-rc1.tar.bz2 entpacken, mit dem Terminal in dieses Verzeichnis wechseln, dann folgendes eingeben (das fettgedruckte muss die Bezeichnung eures Kernels sein):

make
sudo modprobe -r pwc
sudo cp pwc.ko /lib/modules/2.6.17-10-generic/kernel/drivers/media/video/pwc/pwc.ko.saillard
cd /lib/modules/2.6.17-10-generic/kernel/drivers/media/video/pwc
sudo mv pwc.ko pwc.ko.ubuntu
sudo ln -s pwc.ko.saillard pwc.ko
sudo depmod -a
sudo modprobe pwc

(Wie immer gilt, wenn man etwas kompilieren will: Pakete “built-essential” und passender linux-header müssen installiert sein!)

Danach sollte die Cam wieder funktionieren.

14. August 2004

Aktives CD-Laufwerk

Kategorie: — Suzan @ 14:19 Uhr

OK, ob das jetzt wirklich schon “Frust” ist, weiß ich nicht. Aber merkwürdig und nervig ist es auf jedenfall.
Ich mache ja immer brav alle SuSE Updates die mir YOU anzeigt. Will ja sicherheitstechnisch immer auf dem neuesten Stand bleiben. Und außerdem hab ich ja doch die Hoffnung, dass sich nach so nem Update immer mehr Probleme von 9.1 von alleine geben. Nunja, auf jedenfall hab ich das auch am 6. August gemacht, das Update. Und seitdem ist etwas sehr merkwürdigs passiert. Das Fach meines CD Brenners öffnete sich ab da immer wieder von alleine. Egal ob ne CD drin liegt oder nicht, egal ob es gemountet ist oder nicht. Sobald KDE startete öffnete sich das CD-Fach. Ich schließe es, es geht wieder auf. Das ist nicht lustig! :-( Mittlerweile hab ich ja schon wieder 3 oder 4 Updates meines SuSE Systems gemacht. Das Problem hat sich nicht behoben.

Nach langem surfen hab ich schließlich in einem Forum eine “Lösung” gefunden: den SuSE-Plugger deaktivieren. Das Wort “Lösung” ist in Anführungszeichen geschrieben, weil es ja keine richtige Lösung ist. Das Fach öffnet sich zwar nicht mehr ungefragt. Aber eigentlich kann es ja nicht sein, dass man ne Komponente deaktivieren muß, damit der Fehler nicht mehr auftritt. Und es war definitiv erst nach dem SuSE Update. Grrrrrrr….

 
powered by WordPress