hauptseite

7. Januar 2008

Neuer NVIDA Treiber Version 169.07 veröffentlicht

Kategorie: — Suzan @ 22:05 Uhr

Kurz vor Weihnachten, am 20. Dezember 2007 hat NVIDIA den neuen Linuxtreiber in der Version 169.07 veröffentlicht. Der Treiber steht auf der Seite von NVIDIA zum download bereit.

Der neue Treiber ist nicht in den Ubuntu-Quellen verfügbar und wird erst in die nächste Ubuntu-Version einfließen, wie bei Ubuntu üblich. Wer den neuen Treiber also unbedingt haben will, muss also “per Hand” installieren. Für die meisten wird das auch nicht so besonders notwendig sein, für einige schon. Nämlich die mit den Karten GeForce 8800 GT, GeForce 8800 GTS 512 und GeForce 8800M. Die Unterstützung für diese Karten gibt es nämlich nun mit dem neuen Treiber.

Ich persönlich werde den neuen Treiber nicht händisch installieren. Ich habe die Beta-Version des Treibers, Version 169.04, Ende letzen Jahres installiert und ausprobiert. Mittlerweile bin ich aber wie beim in den Gutsy-Quellen vorhanden NVIDIA-Treiber zurückgekehrt.

Grund, warum ich überhaupt den Beta-Treiber ausprobiert habe, war ein Artikel von Phoronix. Dort ist ein eindrucksvoller Benchmarktest beschrieben (auf Seite 2 und 3 des Artikels). NVIDIA selbst schreibt von einer “improved RENDER performance”. Gemeint ist damit alles, was mit XRender zu tun hat. Und was hat alles mit XRender zu tun? Wenn man unter Synaptic eine Suche der Abhängigkeiten von XRender anwirft, bekommt man schon einiges. Compiz, Evolution und Envince zum Bespiel. Oder auch das gnome-panel oder Gimp. Also durchaus wichtige Sachen. Ich habe mir also einiges vom neuen Treiber versprochen. Besonders beim betrachten dieser Benchmark-Tests. Ich selbst habe übrigens einen Laptop mit GeForce Go 7300 Karte.

Ich sag es beim Thema händische Installation von Grafiktreibern immer wieder: macht es nur, wenn ihr wisst war ihr tut.
Könnt ihr euer grafisches System via Konsolenmodus wieder herstellen? Könnt ihr im Konsolenmodus Dateien bearbeiten? Und wisst
ihr auch welche? Seid ihr bei im grausamsten Notfall auch mit einer Neuinstallation des Systems einverstanden? Gut letzteres sollte eigentlich nicht notwendig sein, aber bei Beta-Software weiss man ja nie. Warum sage ich das? Dazu später mehr. *seufz*

Also gut, hier nochmal die Kurzanleitung, wie man den original Treiber von der NVIDIA-Webseite unter Ubuntu installiert. Oder sagen wir, wie ich den Treiber immer händisch installiere:

1. Download Treiber (am einfachsten oben im Home-Ordner abspeichern)

2. Backup der Xorg.conf

2. Compiz deaktiveren

3. nvidia Treiber aus den Ubuntu-Quellen deinstallieren

4. alte xorg.conf umbenennen oder loeschen

5. X neustarten
(Sollte X hier nicht starten wollen, hilft ein “sudo dpkg-reconfigure xserver-xorg” und die Auswahl des nv-Treibers)

6. Zeile
DISABLED_MODULES="nv"

in die Datei

/etc/default/linux-restricted-modules-common

einfügen, damit ihr kein Problem mit euren restricted-modules bekommt und diese nicht deinstalliert werden.
(Ich bin mir nicht 100%ig sicher, ob das bei Gutsy überhaupt noch notwenig ist. Ihr könnt es ja mal ausprobieren, ohne diese Zeile einzufügen.)

7. X beenden:
mit strg+alt+F1 in den Konsolenmodus wechseln, dann
sudo /etc/init.d/gdm stop
X komplett beenden

8. nvidia Treiber installieren
Treiber aufrufen mit:
sudo sh NVIDIA-Linux-x86-169.07.pkg1.run
(Pfad natürlich anpassen, je nachdem wo eure Datei liegt…)

Bei der Installation kommt zuerst die Meldung über ein fehlendes Kernelmodul. Das bitte ignorieren und “Nein” anwählen bei der Frage ob man das Modul runterladen und installieren will.

Bei der Frage ob die XOrg.conf angepasst werden soll, habe ich “JA” gewählt.

9. X wieder starten
sudo /etc/init.d/gdm start

Jetzt ist erstmal alles wieder wie vorher. Ich konnte Compiz sofort aktivieren, ohne an der Xorg.conf etwas zu verändern. Die Option “AddARGBGLXVisuals” “True” scheint nicht mehr nötig zu sein.

Hinweise zur Tastatureinstellung

Beim Anmelden stellte ich fest, dass die Tastatur auf englisch umgestellt war. Es ist also klug, wenn ihr wisst, wie eure Anmeldename und euer Passwort auf einer englischen Tastatur geschrieben wird! 😉
Die Umstellung der Tastatur in Gnome bewirkt, dass unter Gnome das Tastaturlayout richtig ist, der Anmeldebildschirm hatte aber weiterhin das englische Tastaturlayout. Ich habe deshalb ein

sudo dpkg-reconfigure xserver-xorg

durchgeführt. Danach war alles wieder passend.

Ist der neue Treiber nun merklich besser?

Wie gesagt, ich habe den Beta-Treiber 169.04 ausprobiert, nicht den jetzt aktuellsten 169.07. Und beim Beta-Treiber konnte ich genau NULL Verbesserung feststellen. :-( Weder bessere Stabilität, flüssigere Performance oder sonst was. Einfach überhaupt kein Unterschied. Scheint also, dass die Verbesserungen entweder nur bei den neueren Karten richtig rauskommen oder ich einfach nicht die “passenden” Computergewohnheiten habe. Oder ich hätte noch wesentlich länger testen sollen. Keine Ahnung.

Das dicke Ende

Meine Experimentierfreudigkeit hatte diesmal ein unangenehmes Ende. Da der Beta-Treiber keine Verbesserung brachte, wollte ich ihn nun wieder deinstallieren. Die funktioniert, indem man in den Konsolenmodus wechselt und dort ein

sudo nvidia-installer --uninstall

eingibt. Der Treiber wird nun deinstalliert. Habe ich gemacht, X neugestartet, ging nicht. Gut, ein sudo dpkg-reconfigure xserver-xorg und Auswahl den nv-Treibers lies mich wieder ins grafische System. Dort also nun wie gewohnt den Treiber nvidia-glx-new installiert. X beendet, sudo dpkg-reconfigure xserver-xorg erneut eingetippt, diesmal nvidia ausgewählt. X Neustart – geht nicht. Huch? Wieder zurück, nv ausgewählt – geht. nvida ausgewählt, geht nicht.

Dann also mal alles durchprobiert: Treiber nochmal deinstalliert, neu installiert, Xorg.conf direkt im Konsolenmodus bearbeitet, nvidia-glx ausprobiert. Nix. Ich habe es tatsächlich nicht mehr hinbekommen, X mit den Treiber aus den Ubuntu-Quellen zum laufen zu bekommen! Ich habe dann nochmal den Beta-Treiber installiert, mit dem X dann auch wieder lief. Aber nach erneuter Deinstallation und Installation des Treibers aus den Ubuntu-Quellen ging nichts mehr. Der nv-Treiber lief jedoch immer korrekt.

Das System lief also nur noch mit entweder dem nv-Treiber oder dem NVIDIA-Beta-Treiber. Ich habe keine Ahnung warum. Hatte die Deinstallation nicht richtig geklappt? Ein Fehler des Beta-Treibers? Ein Fehler von Ubuntu oder irgendein Fehler von mir? Letzeres ist am wahrscheinlichsten.

Lange Rede kurzer Sinn: nach ca. 1 Stunde rumprobierens habe ich mein System neu installiert. Tja, das muss mir eben auch mal passieren. Da sagt man Newbies, das ist so gut wie nie nötig und dann das. Grrrrr!

Nun gut, ich habe zum Glück mein Home-Verzeichnis sowie meine Daten auf einer extra Partition. Eine Neuinstallation geht also immer schnell und problemlos. Länger dauert da schon das erneute installieren aller zusätzlich benötigen Programme und das Einrichten des Desktops. Jedenfalls habe ich nun mal wieder ein sauberes Gutsy mit dem NVIDIA-Treiber aus den Ubuntu-Quellen. Die Installation desselben nach der Neuinstallation von Ubuntu verlief übrigens problemlos. Scheint also bei meiner Beta-Installations-Orgie irgendwas schief gegangen zu sein. Oder der Beta-Treiber war murks.

Ja.. mir ist dann die Lust vergangen, jetzt die stabile Version des Treibers zu installieren, zumal ja der Beta-Treiber bei mir keinen offensichtlichen Vorteil brachte. Aber ich wäre an Berichte eurerseits interessiert. Läuft der Treiber denn bei euch? Merkt ihr irgendeinen Geschwindigkeits- oder Stabilitätsvorteil?

Ich werde voraussichtlich im Februar oder März sowieso auf Hardy updaten, womit ich mir wieder genügend Alpha und Beta-Zeugs installieren werde. 😉 Bis dahin spare ich mir also einen erneuten händischen Versuch der Treiberinstallation.

Ach ja – dann wird es höchstwahrscheinlich auch wieder viel öfter und mehr Einträge in diesem Blog geben. Aber in letzter Zeit habe ich einfach zu wenig neues ausprobiert und Ubuntu lief halt einfach so. *grins* Ja, langweilig, ich weiss…

18 Kommentare

  1. Na endlich wieder mal ein Lebenszeichen von Dir!

    Ciao!
    Dieter

    Comment by Dieter Pfeiffer Ubuntu Linux Mozilla Firefox 2.0.0.11 am 7. Januar 2008 um 23:22 Uhr

  2. Schön das dir die das mit der Neuinstallation auch mal passiert ist.(freu)
    Nein,im Ernst:Ist mir auch schon öfters passiert.Aber mit einer extra Partition /home für die eigenen Daten ist das doch wirklich kein Problem.Na gut einige Programme und Encoder nachinstallieren und das war`s.Oder?
    Übrings:schön mal wieder was von dir zu hören.

    Viele Grüße Sally

    Comment by Sally Ubuntu Linux Mozilla Firefox 2.0.0.11 am 8. Januar 2008 um 02:04 Uhr

  3. Was erwartest Du für urgewaltige Steigerungen bei einer GF7300Go allein durch eine neue Forceware? Du wirst Dich doch wohl nicht durch Marketingsprüche beeindrucken lassen.

    Wieso hast Du den problemlos laufenden Betatreiber wieder deinstallieren wollen? Nur, weil beta?

    Vor Jahren, als nVidia (wie sie sich damals noch geschrieben haben) ein 3/4 Jahr offiziell auf der Detonator-Version 6.irgendwas (Win, natürlich) verharrt haben, für die zu dem Zeitpunkt neu erschienenen nV-GPUs es keine offiziellen Treiber gegeben hat, wohl aber schon inoffizielle bis über v12.x, habe ich angefangen, nur noch Betatreiber zu verwenden, auf meine Bedürnisse angepaßt. Ich bin stets damit sehr gut gefahren. Was Detonator/Forceware angeht, witzigerweise häufig sogar besser als bei Finals.

    Immerwährende Warnungen vor Betaversionen würde ich nie unterschreiben. Selbstredend muß man bei Crashs aber auch wieder alles zurückbiegen können, zumindest jedoch nicht herumjammern, bleibt nur eine Neuinstallation. Das ist unbestritten.

    Comment by axt Linux Mozilla Firefox 2.0.0.11 am 8. Januar 2008 um 02:25 Uhr

  4. Ich seh’ gerade, bei Dir läuft Sommerzeit.

    Comment by axt Linux Mozilla Firefox 2.0.0.11 am 8. Januar 2008 um 02:27 Uhr

  5. albertomilone.comHallo Suzan, schön wieder was von dir zu lesen!

    Mir ist es auch schon mal so ergangen, damals habe ich auch Stunden damit verbracht den nvidia Treiber mit meiner 8800 GTS zum Laufen zu bringen. Das war auch die Zeit als ich /home auf eine eigene Partition legte… 😉

    Eine Frage, hat es einen bestimmten Grund dass du die manuelle Installation der Verwendung des Tools ENVY (http://www.albertomilone.com/nvidia_scripts1.html) vorziehst? Meine Erfahrungen mit dem Tool sind sehr gut, ich bin begeistert von der Arbeit die der Entwickler leistet!

    Comment by da steg Windows XP Mozilla Firefox 2.0.0.11 am 8. Januar 2008 um 09:55 Uhr

  6. hm, hast du auch daran gedacht die Zeile

    DISABLED_MODULES=”nv”

    wieder zu entfernen?

    Comment by arturh Windows Vista Mozilla Firefox 2.0.0.11 am 8. Januar 2008 um 19:27 Uhr

  7. 7. X beenden:
    mit strg+alt+F1 in den Konsolenmodus wechseln, dann
    sudo /etc/init.d/gdm stop
    X komplett beenden

    Ich habe die Erfahrung gemacht, dass der NVIDIA-Installer meckert, solange man noch in Runlevel 5 ist. Also einfacher und sicherer ist IMHO der Befehl init 3 als root bzw. sudo init 3, und in des Textmodus zurück zu fahren uns sich da als root anzumelden. Nach der Installation des Treibers mit init 5 wieder in den grafischen Runlevel 5 hochfahren.

    Meine Erfahrungen beziehen sich allerdings auf OpenSuse 10.2 und Debian 4 (Etch). Mag sein, dass es bei Ubuntu auch in Runlevel 5 läuft.

    Comment by Markus Debian GNU/Linux Mozilla Firefox 2.0.0.11 am 9. Januar 2008 um 02:26 Uhr

  8. Dies ist ein Testeintrag.

    Comment by Testeintrag Windows XP Mozilla Firefox 2.0.0.9 am 9. Januar 2008 um 10:24 Uhr

  9. Hi Suzan,

    als stiller Mitleser Deiner Site ist mir heute Dein neuer Artikel aufgefallen. Hat mich an den Spruch “Linux ist gut, solange Deine Zeit wertlos ist.” erinnert, den man manchmal liest…:-) Nachdem ich als Gutsy-Newbie auch nächtelang meine Zeit verschwendet habe, wäre es interessant, was bei Dir der neue (Beta-)Treiber in Bezug auf einen sauber funktionierenden S3 (Suspend to RAM = “Bereitschaft” unter Ubuntu) gebracht hat. Denn das ist, obwohl ich einen Desktop mit ganz normaler Hardware habe, mein Show-Stopper Nr 1 für (Ubtuntu-)Linux… Häufig wird nämlich der (proprietäre) Nvidia-Treiber dafür verantwortlich gemacht, dass der Rechner nicht mehr sauber aufwacht…

    Jedenfalls habe ich so ziemlich alles ohne Erfolg probiert:
    – Wiki ubuntuusers/Schlafmodi
    – Wiki ubuntuusers/Nvidia-Grafikkarten/Suspend
    Рalle M̦glichkeiten/Kombinationen in /etc/default/acpi-support getestet
    – Compiz+Emerald deaktiviert

    Unter Windows funktioniert S3 oft monatelang ohne Probleme und ohne einen Reboot, die Hardware sollte es also tun.

    Wie funktioniert eigentlich Dein Notebook in dieser Hinsicht?

    Auch wäre interessant gewesen, ob sich mit dem neuen Treiber nun der TV-Out komfortabler und funktionstüchtiger konfigurieren lässt (z.B. ohne dass Compiz damit Probleme hat (Menü Delay-Problem)). War jedenfalls auch ein ganz schönes Gefrickel mit nvidia-settings, xorg.conf und Compiz-Replace in der Autostart, bis es einigermaßen nutzbar funktioniert hat.

    Unnötig zu sagen, dass unter Windows das Thema mit ein paar Mausklicks erledigt war… :-) Aber egal, ich mache es ja freiwillig, obwohl ich Familienvater bin und das Thema Zeit für mich ein ganz andere Bedeutung hat…:-) Mein nächster Versuch für Ubuntu auf dem Desktop wird dann die Version 8.04 alias “Hardy Heron” sein, in der hoffentlich alles besser wird…

    Ãœbrigens Deine Hardware-Installationserfahrungen sind immer ganz interessant… mittlerweile habe ich meine Logitech Quickcam Pro 9000 auch zum Laufen gebracht und kann mit der Skype-Beta nun auch Videofonieren, allerdings mit nicht gerader toller Bildqualität. Auch Ekiga ist nicht gerade berauschend.

    Bleibt dann noch der PDA- und Handy-Abgleich mit Evolution der nicht geht, ein nicht 100% funktionierender USB DVB-T Stick (kein Diversity (Dual-Tuner)-Betrieb möglich) und noch ein paar andere Dinge… :-) aber das wissen wir ja alle…

    Viele Grüße

    DaUbuntu

    Comment by DaUbuntu Windows XP Mozilla Firefox 2.0.0.9 am 9. Januar 2008 um 10:32 Uhr

  10. Der Beta-Treiber 169.04 hat mich auch gezwungen mein Ubuntu neu zu installieren. Nach der manuellen Installation hat zwar endlich die Display-Beleuchtung meines ThinkPad T61 funktioniert, dafür gingen aber die Compiz-Effekte nicht mehr. Ich habe dann wie Du mehrere Stunden lang versucht den früheren Stand (nvidia-glx-new) wiederherzustellen, alles ohne Erfolg. Zum Glück hatte ich mein Home-Verzeichnis auf eine separate Partition und müsste diese nicht formatieren. Alles ging am Ende gut, hat mich aber mehrere Stunden und Nerven gekostet.

    Comment by Ivan Dolvich Ubuntu Linux Mozilla Firefox 2.0.0.11 am 9. Januar 2008 um 19:24 Uhr

  11. Ein schöner Bericht.
    Mir persönlich ist es allerdings noch nicht passiert, dass ich mein geliebtes Debian neu installieren musste, aber interessant, dass so was doch ab und an passieren kann..

    Comment by Computer-Freak Debian GNU/Linux Mozilla Firefox 2.0.0.8 am 10. Januar 2008 um 03:29 Uhr

  12. Hi Suzan,
    A small note from the Netherlands (my German is not so good, therefore I write in English).

    Ever since the release of Gutsy I have had quite some trouble installing the nVidia driver, but with Envy I have been successful all the time. Since tselliot” updates his tool very frequently I have also used this to install 169.07 with Envy (you can read about this installation here.

    Regards, Omgev Allen

    Comment by Omgev Allen Ubuntu Linux Mozilla Firefox 2.0.0.11 am 14. Januar 2008 um 13:52 Uhr

  13. Netter Beitrag! Aber auch ohne die Schlussfolgerung, dass der Wechsel nichts bringt, hätte ich auf die Installation verzichtet. Ich bin zwar recht experimentierfreudig, hänge jedoch zu sehr an meinem derzeit wie doll und verrückt rennenden System. 😛

    @ Markus: Imho gibts bei Ubuntu nur 2 Runlevel. Runlevel 1 und die identischen Runlevel 2 bis 5. Zwar schluckt das System “init 3″ ohne zu murren, ändert, da 2=3=4=5 ist, jedoch nichts.

    Comment by tAXMAN Ubuntu Linux Mozilla Firefox 2.0.0.11 am 17. Januar 2008 um 18:50 Uhr

  14. Seltsam das zwischen Linux und Windows die Versionsunterschiede so groß sind; obwohl beide Treiber vom selben Hersteller.

    Ich für meinen Teil finde allerdings Nvidia Treiber ausgereifter unter Linux. Linux macht dennoch Spass …

    Comment by winrulz|vista Windows XP Mozilla Firefox 2.0.0.11 am 25. Januar 2008 um 11:11 Uhr

  15. Das gestern erschienene Envy 0.9.10-0ubuntu2 zieht die aktuelle Forceware v169.09 – final, für alle Ängstlichen – (hier unter Gutsy keine Probleme mit GF8600XT). Bereits die Vorversion zieht den aktuellen Catalyst v8.01.

    Comment by axt Linux Mozilla Firefox 2.0.0.11 am 25. Januar 2008 um 12:01 Uhr

  16. Ich hab auf meinem Rechner im Büro nach dem Update auf Gutsy vor ein paar Tagen plötzlich das Problem gehabt, dass OpenGL-Apps X gecrasht haben. Habe dann die 169.04 installiert, und alles war gut.

    Interessant finde ich trotzdem die Frage, wieso Du die Beta wieder deinstallieren wolltest. Gut, Verbesserungen gab es keine, aber Verschlechterungen hast Du auch keine erwähnt…

    Naja, wenigstens musst Du dich nicht mit ATI-Treibern rumärgern. 😉

    Comment by Alexander Heß Ubuntu Linux Mozilla Firefox 2.0.0.11 am 25. Januar 2008 um 22:46 Uhr

  17. Hi,
    ich habe den neuen NVidia Treiber unter Debian Etch am laufen. Probleme habe ich bisher keine feststellen können. :) Läuft alles normal bisher.

    Viele Grüße,
    Heiko

    Comment by Heiko Linux Opera 9.25 am 9. Februar 2008 um 19:43 Uhr

  18. Hi,
    auch bei ist (war) der Leidensweg lang, um Nvidias 169.09 mit einer GF8600GTS einzubinden. Bis jetzt 3x die Treiber drübergebügelt; das Ergebnis: Compiz läuft mit allen Schikanen, Dualmonitoring mit 2 CRT’s aber beim Starten von >nvidia-settings die Meldung, es würden nicht die Nvidia-Treiber benutzt… Sehr possierlich das Ganze. Glaube, ich lass es einfach erst mal so; die Wochenenden sind immer zu kurz..;)
    Herzliche Grüsse
    BM

    Comment by Bob Marlex SuSE Linux Mozilla Firefox 2.0.0.12 am 27. Februar 2008 um 14:36 Uhr

RSS-Feed für Kommentare zu diesem Artikel.

Die Kommentarfunktion ist zur Zeit leider deaktiviert.

 
powered by WordPress