hauptseite

28. April 2008

WLAN LED bei Dell Inspiron 6400 mit Ubuntu 8.04 (Hardy Heron)

Kategorie: — Suzan @ 20:09 Uhr

Wie in meinem Bericht über Hardy geschrieben, funktionieren bei meinem Laptop (Dell Inspiron 6400) ja zwei Sachen bei Hardy nicht, die unter Gutsy funktioniert hatten:

1. WLAN LED geht nicht (das aktivieren/deaktiveren mit den Fn-Tasten aber schon, nur das Licht nicht)
2. Fn-Taste für CD-Fach-Auswurf geht nicht

Für Punkt 1 gibt es eine einfache Lösung, die ich hier kundtun möchte. Ich bin dank eines Eintrages im deutschen Ubuntu-Forum auf die Lösung gestoßen. Es handelt sich um einen “known bug”, für den es auch einen Bugreport (Bug #176090) gibt.

Hier also die Lösung:

1. das Backports Paket für Hardy installieren:
sudo apt-get install linux-backports-modules-hardy

2. ipw3945 Modul entladen und wieder neu laden:
sudo rmmod iwl3945; sudo modprobe iwl3945

Und tadaaaa, die LED leuchtet wieder. Jedoch blinkt sie nicht, sondern leuchtet durchgehend. Korrekterweise leuchtet sie nicht, wenn das WLAN deaktiviert wird.

Ein bisschen Schade, dass dieser Fix nur in die Backports gelangt ist und nicht ins final release.

11 Kommentare

  1. Isch wärd verüggt.
    Watt du so alles im Forum findest… Danke!!

    Comment by bed Linux Mozilla Firefox 3.0b5 am 29. April 2008 um 18:50 Uhr

  2. […] nur so von Meckerkommentaren und konstruktiven Verbesserungsvorschlägen wimmelt. Nun bin ich über Suzans Blog über diesen Beitrag gestolpert. Da brat mir doch einer nen Storch, einfach mal sudo apt-get […]

    Pingback by Zockertown am 29. April 2008 um 19:15 Uhr

  3. Hallo,

    also ich bin leicht frustiert. Bin auch ein relativer Linux-Newbee. Habe mir bei ebay ein neues Dell Inspiron 6400n (also Ubuntu 7.04 vorinstalliert) geschossen. Habe die Platte formatiert und Gutsy draufgeknallt. Lief eigentlich alles – bis auf Firefox und Flash – perfekt. Also am 25.04.’08 dann Upgrade auf Hardy. Seitdem die, in diversen Foren beschriebenen Probleme: Displayhelligkeit, FN-Tasten, WLAN-Leuchte, etc. Standby und Suspend to Ram will auch nicht mehr. Ausserdem hängt sich das komplette System auf wenn ich in einer Website ein Video starten möchte und im Hintergrund noch ne Audioplayer (Amarok oder Videoplayer) laufen habe. Die Browser (Epiphany und Firefox) hängen sich gerne auf. Alles in Allem recht nervig. Bin schon am überlegen wieder zu gutsy zurückzukehren. Was kann man tun?

    Greetz

    Comment by dekl Linux Epiphany 2.22 am 1. Mai 2008 um 10:51 Uhr

  4. Werde auch zu Gutsy zurück gehen!! Das ist mir alles noch viel zu Buggy.. Gestern war auf einmal Sound und Wlan wech. Nervig, echt!!
    Die Linux-Pro’s auf ubuntuusers.de raten aber auch dazu noch bis zur Version 8.04.1 zu warten die im Juli kommen soll. Na denn wird bei mir bis dahin Gutsy laufen. Tolle Website, übrigens!!

    Comment by DocBrown Linux Mozilla Firefox 3.0b5 am 1. Mai 2008 um 11:45 Uhr

  5. bei dem led-workaround muss man vorsichtig sein: ein evtl. vorhandener killswitch kann nach dem patch das wlan nicht mehr einschalten, ohne, dass das treibermodul neu geladen wird. ich musste erst den backport deinistallieren, damit das wieder geht, denn die led ist ja eigentlich weniger wichtig.

    –marsh

    Comment by marsh Linux Mozilla Firefox 3.0b5 am 7. Mai 2008 um 11:34 Uhr

  6. @-marsh

    Das mit dem Killswitch kenne ich, obwohl ich noch 7.04 benutze. Killswitch ist, wenn ich auf FN+F2 klicke, dann wird es angeschaltet, und wenn ich wieder drücke, wieder ausgeschaltet. Nur: manchmal, nach einiger Zeit, funktioniert das nicht mehr. Im dmesg redet er davon, dass ich eine Tastenkombination drücke, die er nicht kennt, und er reagiert nicht mehr darauf.

    Dann wollte ich das Kernel-Modul neuladen, aber weil dieses noch benutzt wurde, ging rmmod nicht. Also doch neustart, schade.

    Comment by Benjamin Ubuntu Linux Mozilla Firefox 2.0.0.14 am 14. Mai 2008 um 19:23 Uhr

  7. Danke dir. Guter Beitrag, jetzt funktioniert endlich mein Lämpchen und mir geht wieder ein Licht auf 😉

    Comment by Flipper Windows XP Mozilla Firefox 2.0.0.14 am 18. Mai 2008 um 10:32 Uhr

  8. Geht nu soweit auf meinem Asus-Lappi
    Muß nur die Finger vom Hardwareschalter lassen.
    Über den Netzwerkmanager läßt es sich aus- und anschalten wie gewünscht.

    Danke. :)

    Comment by susanna Linux Mozilla Firefox 3.0b5 am 1. Juni 2008 um 23:11 Uhr

  9. Geht ebenso bei Thinkpad. Danke, Hast auch nen Tipp, wie man mit der mittleren Multinavtaste und dem Trackwuzel scrollen kann?
    :)

    Comment by limo Linux Mozilla Firefox 3.0 am 5. Juli 2008 um 23:00 Uhr

  10. […] System möglich war. Das erste was nicht ging war die WLAN Leuchte, hierzu fand ich Work-Around bei Susanz Lust und Frust mit Linux der mit meinem Vostro 1310 funktioniert hat. Weitere kleinere Probleme, die eher mit […]

    Pingback by Dell Vostro 1310 und Ubuntu Linux | LuckyKvD´s Weblog WordPress 2.5.1 am 15. Juli 2008 um 01:15 Uhr

  11. modprobe ipw2200 led=1
    ^^^^^^^ durch dein jeweiliges modul ersetzen sollte schon helfen.

    Comment by vaddi Linux Mozilla Firefox 3.0.4 am 25. März 2009 um 22:01 Uhr

RSS-Feed für Kommentare zu diesem Artikel.

Die Kommentarfunktion ist zur Zeit leider deaktiviert.

 
powered by WordPress