hauptseite

11. Oktober 2008

Update zu Ubuntu 8.10 Intrepid Ibex Beta

Kategorie: — Suzan @ 18:59 Uhr

update-intrepidSo, ich habe es dann auch mal gewagt, und mein Hardy auf die aktuelle Beta des kommenden Ubuntu-Releases 8.10 (Intrepid Ibex) aktualisiert. Die finale Version von Ubuntu 8.10 wird am 30. Oktober erscheinen.

Und die obligatorische Warnung: Ubuntu 8.10 ist noch im Beta-Stadium, enthält Bugs und ist für Anfänger nicht geeignet, genauso wenig für Rechner, die dringend für den produktiven Einsatz benötigt werden. Eine Beta-Version ist zum testen da!

Bisher konnte ich nur 2 Bugs feststellen, wobei der eine kein richtiger Bug ist, könnte sogar in einigen Ländern als “Feature” aufgefasst werden. Dieser betrifft die Verbindung zu einigen WLANs, aber dazu Infos am Ende dieses Eintrages.


Ich habe ganz brav über den Update-Manager aktualisiert. Also ein ALT+F2 und dann

update-manager -d

Damit wird der Update-Manager aufgerufen und zeigt auch Entwicklerversionen an, auf die man aktualisieren kann. In unserem Fall wird ein Update auf Ubuntu 8.10 angeboten, welches normalerweise erst NACH dem finalen Release angeboten wird.

Ich habe mal absichtlich nichts gemacht, was ich normalerweise vor einem Update machen würde: ich habe nicht die Fremdquellen in meiner sources.list auskommentiert und ich habe auch nicht den prop. NVIDIA-Treiber deaktiviert. Mal so, wie es später der normale User macht, einfach mit dem System wie es ist auf den Button “Aktualisieren” gedrückt. Ich erwähne nur der Ordnung halber, dass ich natürlich vor dem Update ein Backup meiner Daten gemacht und ich auch eine Neuinstallation des Systems in Kauf genommen habe. Aber ich will ja testen!

Das mit den Fremdquellen bei einem Update ist auch tatsächlich kein Problem mehr, sie werden beim Aktualisieren automatisch deaktiviert:

drittanbieter-deaktiviert

Das Update lief dann mehr oder weniger gut durch. Ich erhielt eine Fehlermeldung bezüglich Samba, die ich mal geflissentlich ignoriert habe. Ungefähr zweimal habe ich auch diese Fehlermeldung bekommen, mit der ich so gar nichts anfangen konnte:

fehler-nm

Ich hab diese dann also erstmal weggeklickt. Nach dem Update habe ich dann einen Neustart gemacht und bin dann gleich mal auf den ersten Bug gestoßen, der mich heute “noch” quält (ich hab erst gestern das Update gemacht): beim Herunterfahren bleibt mein Rechner bei der Meldung “Shutting down ALSA” hängen. Ich habe gedacht, der Rechner steht total und habe nach ner Weile “gewaltsam” ausgeschalten. Mittlerweile hab ich das ein paar mal ausprobiert. Es ist so, dass der Rechner schon runterfährt, nur da eeeeewig hängenbleibt. Ich weiß nicht genau wie lange. Ich habe den Rechner heute auf jedenfall runtergefahren, bin dann Duschen gegangen und wie ich wieder kam war er auch ganz normal ausgeschalten. Das Problem habe ich bisher jedesmal beim Runterfahren, bedarf noch einer genaueren Investigation.

hardware-managerAls ich dann Hochgefahren habe, hatte ich erstmal keinen X-Server, nur eine Fehlermeldung, dass etwas mit den Einstellungen nicht stimmt. Man hat dann drei Sachen zur Auswahl, wenn ich mich recht erinnere. Eine Backup-Konfiguration verwenden, Ubuntu versucht selber den X-Server zu konfigurieren oder Ubuntu mit der “normalen” grafischen Einstellung starten, dass heißt also ohne proprietäre Treiber. Ich verwende eine NVIDIA GeForce Go 7300, heisst also mit dem nv-Treiber starten. Ich habe erst die Option probiert, dass Ubuntu selber den NVIDIA-Treiber konfigurieren sollte, hat aber nicht geklappt. Dann habe ich das System mir den Standard-Grafikeinstellungen starten lassen, also mit dem nv-Treiber. Das hat dann auch anstandslos geklappt.
Hierzu muss ich aber anmerken, dass ich vorher den NVIDIA-Treiber zwar nicht händisch, jedoch über Envy-NG installiert hatte. Hat das vielleicht schon mal jemand von euch probiert, der den normalen NVIDIA-Treiber aus den offiziellen Quellen installiert hatte? Hat es da beim Update gleich geklappt?

Das ist jedoch nicht Tragisch, da man ja ein grafische System bekommt. Ich habe den NVIDIA-Treiber dann mit dem Hardware-Manager innerhalb ein paar Sekunden installiert und nach dem nächsten Neustart hatte ich ihn dann aktiv. Bei Intrepid in der Version 177.80. Wie ihr am Screenshot sehen kann, werden drei Versionen des NVIDIA-Treiber angeboten. Einige ältere Karten haben ja anscheinend ein Problem mit der neueren Version.

Was gibt’s denn nun alles in Intrepid? Im Moment Kernel 2.6.27-7, GNOME 2.24, X.ORG 7.4 und viele aktualisierte Programmversionen. Ihr könnt mal einen Blick auf die Ubuntu-Seite werfen für einen groben Ãœberblick.

Problem und “Lösung” mit WLAN in Intrepid

Eines der wichtigsten Sachen für mich ist eine Internetverbindung. Seitdem ich einen Laptop habe auch ein funktionierendes WLAN. Mein Laptop hat eine Intel 3945-WLAN-Karte, die bisher auch immer ohne jeglichen Probleme funktioniert hat. Selbst mit Windows-Rechnern konnte ich (und kann jetzt auch wieder) nicht so einfach mit einem WLAN verbinden wie mit dieser Karte und dem Network-Manager. Einfach Netzwerk aus der Auswahl auswählen, Passwort eingeben, geht. So war ich das bisher auf jedenfall gewohnt.

Nun das Kuriose: der Network Manager zeigte mir mit Intrepid alle möglichen verfügbaren WLANs an – nur nicht mein eigenes!!! Am Router hab ich natürlich nichts verstellt, eine halbe Stunde vorher mit Hardy wurde es mir ja auch noch angezeigt. Nun mit Intrepid nicht mehr. LAN kein Problem, auch WLAN funktioniert, habe mich testhalber mit einem offenen WLAN verbunden ohne Probleme. Aber mein eigenes Netz war nicht zu finden. Weder in der grafischen Ansicht des Network-Managers, noch über einen iwlist-Scan. Hö, wie jetzt? Ich glaube so doof und hilflos hab ich mein Ubuntu schon lang nicht mehr angeglotzt. Ich hab dann auch versucht den Treiber zu entladen und wieder zu laden, was natürlich nix gebracht hat. WLAN ging ja… nur halt meines war weit und breit nicht zu finden.

Aber zum Glück gibt es ja das UbuntuUsers-Forum wo man selbst zu solchen merkwürdigen Problemen Hilfe bekommt. Ich habe dann auch Hilfe bekommen.

Hier die Auflösung des Kuriosums:

Mit dem Kernel von Intrepid werden nur noch Funkkanäle von 1 bis 11 unterstützt. Wenn das WLAN also zufällig auf Kanal 12 oder 13 ist, wird dieses nicht mehr erkannt und eine Verbindung ist nicht möglich. Nicht zu erwähnen, dass mein WLAN natürlich auf Funkkanal 13 eingestellt und deswegen nicht mehr sichtbar war.

Nach der Umstellung des Kanals auf 11, war wieder alles in Butter. Netzwerk ist wieder sichtbar, Verbindung kein Problem. Nutze übrigens WPA-Verschlüsselung, nur so nebenbei.

Und hier der Hintergrund des Ganzen:

Is it a bug or a feature? Für uns in Deutschland ist es klar ein Bug. Jedoch ist es so, dass in einigen Ländern dieser Welt, wie z. B. in den USA, die Benutzung der Funkkanäle 12 und 13 illegal ist. Da funken wohl staatliche Stellen wie die Polizei herum in diesen Ländern. In Deutschland oder auch Australien sind diese Kanäle allerdings völlig legal und werden auch häufig benutzt.
Im neuen 2.6.27 Kernel wurde die Unterstützung für diese Kanäle jetzt aber gekappt, wohl um sicher zu gehen, nicht in die Illegalität zu fallen.

Das Ganze ist natürlich ne total doofe Situation. Ich kann verstehen, warum das gemacht wurde. Jedoch ist es für uns hier richtig beschissen. Man kann sich halt nie sicher sein, mit einem fremden WLAN eine Verbindung zu bekommen, weil man ja nie weiß, ob das evtl. auf Kanal 12 oder 13 funkt. Könnte in Hotels richtig doof sein. Mal sehen, ob es dazu noch Diskussionen gibt.

Für euer eigenes Heim-WLAN ist es jedoch keine größeres Problem, da Ihr ja einfach einen Kanal von 1 bis 11 auswählen könnt.

Ach ja, das hier besprochene Problem hat sich nun auch in Wohlgefallen aufgelöst. Die WLAN-LED meines Laptop blinkt wieder, wie es sein soll. Ist auch aus wenn ich WLAN deaktivere und wieder an wenn ich es aktivieren. Sehr schön.

Und sonst?
Ja, läuft gut und stabil. Viel mehr kann ich nach ein paar Stunden noch nicht sagen. Das Problem beim Herunterfahren muss ich noch lösen. Aber ansonsten sehr schön. Wie fast immer gibt es keine besonders augenfälligen Neuerungen. Aber ich werde weiterhin berichten … stay tuned… 😉

20 Kommentare

  1. auch ich hab vor kurzem auf intrepid aktualisiert. ich hatte den nvidia-treiber aus den repos installiert und es gab nach dem update keinerlei probleme

    Comment by logge Windows XP Mozilla Firefox 3.0.3 am 12. Oktober 2008 um 14:30 Uhr

  2. Ich habe frisch installiert und arbeite via WLAN eh modifiziert, von daher gab es keinerlei Sorgen bei der Installation. Läuft alles mehr als prima muss ich sagen. Nur die Tablet Funktionalität kann ich nicht zum laufen bewegen. Nvidia Treiber laufen auch. Also, alles bestens.

    Comment by shakal Ubuntu Linux Mozilla Firefox 3.0.3 am 12. Oktober 2008 um 15:59 Uhr

  3. aaah Suzan ist wiedererwacht, gab ja ewig nix mehr zu lesen hier. Da fragt man sich ob sie ihr Linux in die Ecke geworfen hat

    Comment by gnokii Ubuntu Linux Mozilla Firefox 3.0.3 am 12. Oktober 2008 um 16:10 Uhr

  4. Es gibt einen kleinen Fix, den ich für Debian gefunden habe, der natürlich unter Ubuntu auch funktioniert.

    Erstelle eine Datei /etc/modprobe.d/iwl3945 und schreibe dort rein:
    options cfg80211 ieee80211_regdom=”EU”

    Dann das Modul neu laden:
    rmmod iwl3945
    modprobe iwl3945

    Fertig, und du solltest wieder Zugriff auf alle APs mit Channel 12 und 13 haben.

    ~jug

    PS: Debian lenny mit dem 2.6.26er Kernel benötigt statt “EU” ein “JP”…

    Comment by jug Ubuntu Linux Mozilla Firefox 3.0.3 am 13. Oktober 2008 um 08:46 Uhr

  5. Also, ich habe den gleichen Laptop wie Du (Dell Inspiron 6400) und bei einer Neuinstallation kommt das Problem mit dem herunterfahren nicht vor. Keine Ahnung wieso??!!

    Comment by Frankie Ubuntu Linux Mozilla Firefox 3.0.3 am 13. Oktober 2008 um 19:50 Uhr

  6. Was ist denn WAP-Verschlüsselung im wlan? 😀

    Comment by bladovitch Linux Konqueror 4.1 am 15. Oktober 2008 um 14:29 Uhr

  7. Aber sonst wie immer ein sehr informativer Berich… das hatte ich vergessen :)

    Comment by bladovitchnochmal Lynx 2.8.7dev.10 am 15. Oktober 2008 um 14:34 Uhr

  8. Hört sich ja schonmal gut an… Ich werd allerdings noch bis zur final mit dem Update warten.

    Comment by n0x Ubuntu Linux Mozilla Firefox 3.0.3 am 17. Oktober 2008 um 12:05 Uhr

  9. Die Fehlermeldung zu den fehlenden Ressourcen für das Network Manager Applet kommt immer dann, wenn eine Datei nicht gefunden wird, die das laufende Tray-Icon benötigt. Wenn du z.B. ein neues Icontheme installierst, das kein Icon für den Network Manager bereithält, erscheint sie ebenfalls. Vermutlich wird da während des Upgrades irgendetwas verschoben, der NM merkt das sofort und spuckt die Meldung aus … Nichts Schlimmes jedenfalls. :)

    Comment by Kelhim Linux Mozilla 1.9.0.3 am 19. Oktober 2008 um 19:58 Uhr

  10. Hey Suzan,

    wenn ich deine Probleme lese mit 8.10 Beta, dann hast du keine, wenn ich mich mit meinem artfremden Laptop von HP (6715s) aufmache Ubuntu 8.10 beta zum Laufen zu bekommen.
    Aber mal ernsthaft, ich bräuchte dringend einen Kontakt zu den Ubuntu-Entwicklern, denn ich befürchte, dass mein HP beim endgültigen release auf der Strecke bleibt oder vielleicht kennst du ja den einen oder anderen; hier die shorts:
    – 64bit alternative 8.10 beta cd (versucht) zu installieren : dauerte über 2 Stunden (was wirklich ungewöhnlich ist)
    – Zu beginn forderte mich 8.10 auf den IOMMU im Bios zu aktivieren und 64 mb frei zu machen; leider verfügt der
    Schläppi nicht über solche Bios – Einstellung
    – Ansonsten hatte ich ein ok beim Hochfahren
    – Lüfter lief nach Installation und erstem Hochfahren auf Vollgas
    – Prozessor zu 100% ausgelastet
    РEin arbeiten nicht m̦glich und Entwickler benachrichtigen aus 8.10 heraus nicht m̦glich, weil jede Bewegung ein
    echtes Schneckenerlebnis war.
    – Für eine beta ein Grauen…. wenn man HP mit AMD und ATI nutzt…

    gruss knuutsen

    Comment by Knuutsen Windows XP Mozilla Firefox 3.0.3 am 22. Oktober 2008 um 02:00 Uhr

  11. Bei mir erkennt der Hardware-Manager die nVidia-Treiber nicht. Ich hab nur ein Fenster mit leeren Kästchen, wo ich nichts auswählen kann :( Unter Hardy lief noch alles fluffig.

    Comment by Bernd Windows XP Mozilla Firefox 3.0.3 am 23. Oktober 2008 um 16:38 Uhr

  12. Hallo, ich habe brav das 8.10 auf die 8.041 Ubuntu-Version aktualisiert. Man will ja aktuell bleiben. Aber seitdem spinnt mein 845c von HP (Drucker) und vor allem: Die Grafikauflösung ist so unscharf, dass ich lieber in 8.041 geblieben wäre. Da war alles sauber und klar. Wie bekomme ich nun den Nvidia-Treiber aktualisiert. Ich bin Trial-and-Error-User und hab nich jeden Tag die Nerven stundenlang Internet zu studieren, um das Ding ans Laufen zu bringen. Zum Glück kann ich ins Internet. DHCP sei dank. Aber ich brauch hilfe, dass der Drucker und die Grafik wieder klappen – und wer weiß – vielleicht kann ich jetzt noch nicht erkennen, was noch hakt.

    Gruß
    BB aus Köln

    Comment by Bernward Ubuntu Linux Mozilla Firefox 3.0.3 am 23. Oktober 2008 um 17:28 Uhr

  13. Zur nVidia: Seltsame Sache. Hab envyng installiert und damit die aktuellen Treiber installieren lassen und plötzlich fängt der Hardware-Manager auch wieder an, dass er was erkannt hätte. Dummes Ding!

    Comment by Bernd Windows XP Mozilla Firefox 3.0.3 am 24. Oktober 2008 um 14:22 Uhr

  14. Hallo,

    ich überlege noch, ob ich beim Computer meines Vaters auf Ubuntu 8.10 aktualisiere. Im Computer ist noch eine GeForce4MX verbaut, welche aufgrund fehlendem CSS Treiber wohl nicht mit dem aktuellen Xorg zurecht kommen wird. Ich hoffe, dass nVidia doch noch Legacy Treiber für die aktuelle Xorg nachreicht. Ansonsten wird es wohl 8.04.x bleiben. :)

    Gruß,
    Heiko

    Comment by Heiko Solaris Mozilla Firefox 3.0.1 am 25. Oktober 2008 um 18:16 Uhr

  15. Hallo,

    wenn du in der /etc/modprobe.d/alsa-base die richtige Option für deine Soundkarte einstellst, fährt der auch normal runter.

    Bei mir auf nem Sony-Läppi musste ich

    options snd-hda-intel model=vaio

    eintragen.

    Viele Grüße

    Comment by Leander Ubuntu Linux Mozilla Firefox 3.0.3 am 31. Oktober 2008 um 14:55 Uhr

  16. Hallo,

    ich habe jetzt doch auf allen Ubuntu Rechnern auf Intrepid Ibex aktualisiert. Läuft überall ohne Probleme. Mein Vater ist auch begeistert. (Er kommt auch ohne 3D Beschleunigung aus). :) Und wie ich gelesen habe, hat NVidia auch schon einen Beta-Treiber für die alten Grafikkarten in der Entwicklung.

    Gruß,
    Heiko

    Comment by Heiko Solaris Mozilla Firefox 3.0.3 am 9. November 2008 um 19:01 Uhr

  17. Hast du das Problem mit dem herunter fahren schon gelöst?stehe seit Tagen vor dem gleichen Problem.Im Ubuntu Forum bin ich auch nicht weiter gekommen.

    Gruß Jeff

    Comment by Jeff Ubuntu Linux Mozilla Firefox 3.0.3 am 14. November 2008 um 13:34 Uhr

  18. Ja, siehe 4 Eintrage weiter:

    http://mylinux.suzansworld.com/?p=321

    Comment by Suzan Ubuntu Linux Mozilla Firefox 3.0.3 am 14. November 2008 um 19:11 Uhr

  19. hmm nee
    Bei mir ist das doch etwas anders.
    Ich habe z.b garnicht die Meldung die du hast(Shutting down ALSA)
    Das habe ich vorhin wohl ein wenig überlesen :-)

    Meiner fährt jedenfalls soweit runter das nur noch ein kurzer druck auf den off Schalter notwenig ist.Also keine Meldung oder sonst was.
    naja mal weiter sehn

    Interessante Seite übrigens.Hab ich vor nem Jahr mal zufällig entdeckt.

    weiterhin gutes gelingen

    Grüß Jeff.

    Comment by Jeff Ubuntu Linux Mozilla Firefox 3.0.3 am 14. November 2008 um 22:45 Uhr

  20. lidux.deHier gibt’s Desktopvideos von Ubuntu, Kubuntu und Xubuntu 9.04 und anderen Linux-Distributionen: http://www.lidux.de/linux

    Comment by Marcel Windows XP Mozilla Firefox 3.0.8 am 10. Mai 2009 um 15:40 Uhr

RSS-Feed für Kommentare zu diesem Artikel.

Die Kommentarfunktion ist zur Zeit leider deaktiviert.

 
powered by WordPress